Results 1 to 4 of 4
  1. #1
    Regular
    Join Date
    Feb 2014
    Posts
    29
    Post Thanks / Like

    Question Claro texting problems

    Hi guys! I just arrived today, headed to Sosúa. I got a Claro SIM for my iPhone 5c, and everything works. Except. I can call and text and receive same to/from DR numbers just fine. I can call and receive calls to the US. I can receive texts from the US as well. But I just can't send texts. The Claro kiosk at SDQ was unhelpful. After a couple minutes of poking they shrugged and handed it back.

    I am using 1 before the area code, but I also tried +1 and then the number. No go. This evening I took it to the corporate store on St Vincent in SD. I got way in over my head with my Spanish, although I *think* I learned I'd never be able to text ATT customers. I don't care about that network, but I do need to text Verizon subscribers. (My family is on vzw). When I came last year with a little crappy flip phone, I had no issue at all texting US people.

    Have you damas y caballeros got any ideas or input? Barring ideas, I'm going to go to Orange tomorrow and see if they have a similar issue. But I've already got some money into this, so if I can roll with it, I'd like to- unless you think I *should* go with Orange. I'm open to suggestion!

  2. #2
    DR1
    Join Date
    Jan 2009
    Posts
    21,111
    Post Thanks / Like

    Default

    Maybe consider getting the Viber or What's App for your phone and ask your family/friends to do the same, assuming they have smartphones. Apps are free, texts are free, so are calls.

    Administrator
    DR1.com

  3. #3
    Regular
    Join Date
    Feb 2014
    Posts
    29
    Post Thanks / Like

    Default

    But that requires data, no? Also my prepago situation somehow allows me to use data even though I said specifically I didn't want it at this time- does anyone know at what rate it eats into your account?

  4. #4
    Regular
    Join Date
    Feb 2014
    Posts
    29
    Post Thanks / Like

    Default

    I found the solución to the problem. I'd been using 1 or +1, and found very few that it worked for. But 001 seems to work across the board.

  5. Likes Uzin liked this post

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •